Hi-Point Firearms Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey. Im a noob, the 995 being my first firearm. I got a new 995, and before ever firing it, mounted the ATI stock. I have 2 mags, and both of them are very loose in the mag well...they cause jams unless I hold the mag in with my pinky. The drop down too low....like my catch is mounted wrong..this just made me think...did I load my catch upside down, is that possible?
 

·
Registered
Joined
·
850 Posts
The spring on the mag release is kind of shady. If you don't put it in there just right it may not be catching the mag really well. I thought when I put my new stock on that it made the mag catch a lot smaller anyways. I would just take that apart again and make sure everything is in working order. There's also a how do about the ATI on the forum somewhere too and there's pictures about how all of that stuff is supposed to look.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Allright took it all apart. The mags are REALLY loose and jiggle around inside the well. Messing with the catch did nothing. I wrapped some tape around the mag, and that helps, but its obviously not the best solution. It is almost like the hole on the mag that the catch slips into is too big/too low on the mag.

Has anyone else with an ATI stock had this problem?
 

·
Registered
Joined
·
249 Posts
Don't know if it was an assembly issue with your ATI, but mine works very well with both the 8rd and 10rd mags. I followed the write up here on the forum when installing the stock.
 
1 - 4 of 4 Posts
Top