Hi-Point Firearms Forums banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Hi, I'm new to the forums and I just started firing my C9 today. I bought it two weeks ago and have left the magazine loaded since then. After I fired the first round it seemed the C9 didn't cycle and recock. I tapped it on the back and it fired the next round. I would do this again for the next two rounds. I eventually figured out that if I only loaded 5 rounds in mag it would cycle, but anymore and it wouldn't recock. Am I correct in assuming that this is a mag spring issue and it just needs to be broken in over time?
 

·
Registered
Joined
·
959 Posts
actually, it sounds more to me like you have a weak mag spring...
but maybe someone more knowledgeable will speak up...
 
G

·
Discussion Starter · #3 ·
yup sounds like a weak spring to me. if you want you could always open the mag up and give the spring a little stretch...i probably would but im not tell you to :p if you are comfortable trying it go for it...i mean a new 8 round mag is like what 14 bucks. but i donno. if all else fails the people at HP are awesome and will replace your mag for free most likely.
 
G

·
Discussion Starter · #4 ·
actually, it sounds more to me like you have a weak mag spring...
but maybe someone more knowledgeable will speak up...
and i should add if you didnt notice im a newbie and maybe i should recommend doing anything considering unreconstructed1
HPFF Distinguished Expert isnt sure.

sorry :x
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top