Hi-Point Firearms Forums banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I just got my hi-point C9 two days ago and I have not had a chance to fire it. In examining it, I have noticed that it produces a weird metallic clicking sound as I pull the slide back to cock it. Sometimes it sounds kind of like rubbing a taught metal wire along a rough surface other times it is like a distinct clicking. The sound is subtle, but it is usually there.

Once it is cocked, the pistol no longer makes that sound when I pull the slide back. I am aware of the drop safety and that is a different sound.

Do I have anything to worry about (does your C9 make such a sound?).
 

·
Registered
Joined
·
51 Posts
Does it sound like two springs rubbing together? There are two firing pin springs, a long, small diameter spring riding inside a short, larger diameter spring. Noticed this on mine too.
 
G

·
Discussion Starter · #4 ·
Yes! it sounds exactly like two springs rubbing togeather. So are you saying this is a normal thing?

Sorry to be all paranoid, it is my first gun (raised around them, but never owned one before) and I am just making sure that everything is A-OK
 

·
Registered
Joined
·
51 Posts
To be honest, I never noticed the sound until I removed the slide for cleaning and the springs flew out! When I went to reassemble, I noticed that the long spring had a slight kink to it. Put it back together and it made a noticeable noise, so I took it apart, straightened the spring as best I could and back together again. Still made the noise, but not as much. I was worried too, but I took it to the range the following weekend and everything appeared to be working properly.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top