I need help with my trigger install !!!!!!!!!!!!!

Discussion in 'Vintage Topic Archive (Sept - 2009)' started by hitmanharleyk, Jan 26, 2008.

  1. As I was trying to put Bushman trigger in the black pc it hooks to fell out,
    I can't figure out what it hooks too !!!!

    I'm one pissed off fellow, sometimes you need to leave good enough alone !
     
  2. 47_MasoN_47

    47_MasoN_47 You know who I am Member

    Are you talking about that little thingy that you put the small pin in the trigger through?
     

  3. Alright Hitman, take a couple of breaths..... ok, can you explain what happened again, I don't understand what "in the black pc it hooks fell out" means.
     
  4. yes I am, i put it where I thought it should go, put the gun together no fire !!!!
     
  5. 47_MasoN_47

    47_MasoN_47 You know who I am Member

    Could you take a picture of it? That would probably help us figure out what needs to be moved.
     
  6. It is the thing that fastens ti the small pin in the trigger, the spring goes against it.
     
  7. warwemust

    warwemust Guest

    I had a little difficulty with that last night placing mine. If you put the pin half way in first and have a good light you should be able to line it up. I think the c9 went easyer, I just finished that. But I had that same problom and solved it after a beer. LOL Just take a break , get good light and place the small pin halfway in , line it up and press it thru. It took me 1 hr. with the carbine and about 30 min with the c9. I have never done this type of gun work befor.
    U can see mine posted in the pic gallery.
     
  8. lining that pin up isn't the problem, the pc the trigger attaches to fell out of the gun, I think I have it back in right but the won't even dry fire.
     
  9. 47_MasoN_47

    47_MasoN_47 You know who I am Member

    Ok so that piece fell out? I don't think it's supposed to come out... Have you taken the slide off to see if you can find what it's supposed to connect to or did you just sortof stick it back on there?

    By the way, I don't mean that to sound condescending just covering all possibilities.
     
  10. got the gun apart right now looking at it, but can't tell

    It was real loose to start with.

    It looks like it pushes on another pc to make the gun fire of course, then the slide catches it on the way back to set it to fire again.
     
  11. Hitman, had to change computers right quick. Ok that piece that attaches to the trigger can come out if you twist it just right... I took mine out to look at it to see if polishing it would give me a beter feeling trigger.

    One thing to make sure is that the tiny spring did not fall out while you were putting it back together. That tiny spring is critical to the mechanism working.
     
  12. This si what its supposed to look like:

    [​IMG]

    Make sure both arms are spring loaded up. If either is loose, then there may be a problem.
     
  13. warwemust

    warwemust Guest

    That spring stayed in mine fine but lining up that small pin gave me hell for about 10min. LOL. The spring kept falling out of the c9 though, during instalation.
     
  14. took it back apart, spring was right were it should be.
     

  15. That is what i had, but it would only dry fire about every 5th pull

    Putting the plastic one back in to see if it works.
     
  16. OK, could you feel the mechanism loading up.... like you were pushing against a spring... but then you bottomed out and no SNAP!
     
  17. I put the plastic trigger back in and it fires everytime !!!!!!
     
  18. Well, looks like there may be an issue with the trigger I sent, Hitmanharleyk.

    A full refund has been offered. If any of you guys who bought a trigger and is having probmes with it, please PM me to see if we can solve it and if not, this offer stands. Full refund for 60 days.