Linux discussion!

Discussion in 'Lounge' started by bluharley, Dec 29, 2014.

  1. bluharley

    bluharley Member

    When XP was retired, my old 32 bit laptop couldn't run the 64 bit Windows 8, so I installed Ubuntu. But Ubuntu is heavy and ran real slow. So I tried Puppy, and it brought new life to the old machine. Faster than anything I've had on it. So I thought I'd try it on my Gateway. Well, I can't get it to run from DVD or Flash Drive. So I read about getting around the UEFI. So I follow the procedure, but it just takes me into the old BIOS and those settings don't help. I've tried disabling Secured Boot and everything else, but no go. I've read a little about how some manufacturers block the ability to run any other os than the one shipped. But that procedure that supposedly bypasses the old BIOS, but doesn't work. I'm stumped. I'm thinking Gateway and Microsoft conspired to prevent anything else ever running on this POS. Any suggestions?
     
  2. Johnny_B_Goode

    Johnny_B_Goode Member

    218
    1
    If your computer is running USB 2 you should be able to boot from a flash drive. I just bought a 128 gig kingston flash drive for right at $50.
     

  3. bluharley

    bluharley Member

    It has USB 2 and 3. I've tried a Flash drive in USB 2, I've tried a live cd. This thing just doesn't see it. I have a recovery partition on a USB drive that I have used before, but that's a Windows thing, again. Nothing but Windows works on this POS.
     
  4. Back2School

    Back2School Member

    1,190
    0
    Deleted. Too late at night to think technically...
     
  5. mr_flintstone

    mr_flintstone Supporting Member

    What model number is the Gateway? Is it a 32 bit or 64 bit computer? Some things can cause a CD/USB boot failure with UEFI/BIOS computers. You can try Legacy mode in the UEFI/BIOS and check to see if Secure boot is enabled or not. What version of windows did it have on it, and what version of puppy are you trying to install? If your UEFI has secure boot enabled, you may need to disable it or try Fatdog 64 or Lighthouse 64 versions of Puppy.
     
    Last edited: Dec 30, 2014
  6. lklawson

    lklawson Staff Member

    I hate UEFI. It's caused me nothing but trouble.

    GRUB2 has a bug in it that doesn't work well with EFI.

    You can usually get around it by working in "Legacy" mode in the setup, as has been suggested.

    You might need to flash the newest firmware version.

    Peace favor your sword,
    Kirk
     
  7. Branth

    Branth Member

    6,275
    4
    UEFI sucks. I've had to tinker with it a few times where I work to try and load up Ophcrack.
     
  8. I had a computer that I replaced XP with Lubuntu and Mepis, both ran though Ubuntu would not. I don't like Ubuntu anyway, IMO, Lubuntu is much better. Because it is lighter, much quicker. The computer finally died a couple months ago, so I ended up buying a refurbished dell to replace it, with Windows 7. At some point I will probably add a partition for Mepis.

    Sad part was I had just replaced the CPU to a faster one, and added more memory to get it up to speed. It was actually faster than my wife's one year old lap top until it broke down.
     
  9. bluharley

    bluharley Member

    Well, apparently I have the latest firmware from gateway. I went into BIOs and disabled Secure Boot, and went to legacy. It looked at my flash drive but said there was not an operating system on it. Could be the flash drive. When I went to reconfigure the BIOS for Boot Priority, the options were strange and there was no option for CD/DVD. So I let boot to Windows, went back to BIOS and everything was back to normal. I guess I'll just leave it alone, I don't want to end up with a paperweight.
    The BIOS version I have says it has an "optional" UEFI support. Not sure if that means it's optional when installed, or it means the supposed work around that doesn't work. I hate Microsoft, they are evil.
     
  10. I am sure your flash drive was set up properly, but if you just copied the software to the USB it will not boot. The computer looks for an image to boot, that means the flash drive must be made bootable, and a image burned to the USB by one of the programs designed for it.

    I believe your USB must be formatted FAT to be made bootable.

    I did not change anything on my old computer that I built with a intel 8000 series board. Dell and Gateway use the intel board considerably. I did not change any of my bios settings for Mepis and Lubuntu to operate smoothly. It may be possible that the Ubuntu you are trying to use is a 64 bit version. When I tried to use Ubuntu it would not load, but after I changed to a SATA optical it loaded without problem, I just don't like it. You may also have to change to a SATA optical, not sure why that makes a difference, but it did in my case.
     
    Last edited: Dec 30, 2014
  11. bluharley

    bluharley Member

    My old 32 bit laptop loads anything I give it. My 64 bit Gateway is the problem. I make a disc image to boot from. My laptop boots fine off the cd, my gateway does not. I'm sure it's this UEFI crap. What BS. They sell you a computer that will only run Microsh!t, there should be a law against it. I'd never heard of UEFI til now, it should be considered a virus.
     
  12. ajole

    ajole Supporting Member

    34,497
    10,711
    NE Utah
    There are branches or builds of most Linux distros that can be put on UEFI boxes, but I agree, it's a rotten bunch of MS crapware that they forced on the planet.

    I used to like Puppy, Vector, and Nimble X quite a bit for my old low RAM boxes. The lighter versions of Ubuntu are great too.

    I fiddled with a Ubuntu install on a UEFI box last year, tried several flavors, never did get it right.:(
     
  13. It may be a problem with your optical, it was in my case. Replaced the IDE optical with a SATA and it loaded Linux without issues.

    But the windows 8.1 laptops will not load Linux without changing the BIOS. I hate Windows 8/8.1 but my wife is OK with it. Windows 7 also has some glitches, both 8 and 7 will not recognize some old USB external hard drives. I do not use them much anymore though. And I have read that some old flash drives will not work on the later boards.

    BTW I am running a Dell 755 SF 64 bit. Using the SATA optical from the now dead computer it loads every 32 bit distro of Linux I have. So far I see no need for a 64 bit distro. It has a intel board though system information lists Dell board. I had a driver problem with it until I loaded the intel drivers.

    Dell 755 are not supposed to be Windows 7 compatible, but after finding the correct drivers from intel mine runs like a champ. Be careful of buying refurbished computers with Windows 7 because if you are not very good at digging for correct drivers you may be disappointing. It took me a couple days to get mine working as it should be. It loaded Linux no problems and without searching for drivers.

    Your Gateway 64 bit may have a very similar board to my Dell 64 bit. If you still have Windows XP in it go to device manager, you should be able to see each component description. Betting you will find they are intel.
     
    Last edited: Dec 30, 2014
  14. Dane

    Dane Supporting Member

    10,322
    2,086
    Florida

    What died on it??
     
  15. It just starting dumping memory, until it finally would not boot. Hard drives checked out fine. It was running hot on Linux, something Linux users should keep an eye on. Normally with XP it sometimes turned on one of two additional cooling fans. With Linux both additional fans ran all the time. But Linux was much faster. I probably should have slowed the clock speed down. I have not pulled the board yet, but probably I lost some capacitors from the heat.
     
  16. If you want to try a Linux Distro that works on about about anything try PCLinuxOs Mate it comes in 32 and 64 bit. I've put it on several computer from Laptop to Desktop replacing Windows 8.1 with it. Its comes with everything to make it work on a Live CD or you can use unetbootin to install it on a flash drive and make it bootable. I quit using windows in 2005 now run nothing but Linux.

    Hope this helps you.
     
  17. lklawson

    lklawson Staff Member

    I can second the ease of use on PCLinucOS. It's what I use at home on my personal stuff.

    Peace favor your sword (mobile)
     
  18. bluharley

    bluharley Member

    Well, I made an image of the PCLinux, but this Gateway will not boot from it. I need to try another disc image software, but I'm out of DVD's.
     
  19. mr_flintstone

    mr_flintstone Supporting Member

    So many PCs and BIOS/UEFIs have slight differences, it may be difficult to track down. Here is a pretty good help page from Ubuntu. Even if you don't use Ubuntu, it has some pretty good info that may be useful. I hope you get it figured out.
     
  20. bluharley

    bluharley Member

    Aha! I bet it's that fast startup option. I'll check it out a little later, I'll let you know. Thanks!