New to forum - .40 having FTF problems.!

Discussion in 'Hi-Point Pistols' started by ShadowTX, Jan 3, 2016.

  1. ShadowTX

    ShadowTX Member

    6
    0
    First round will load and fire second jams on feed ramp almost all the time.
    HELP.!!!!!!!!

    .40 S&W pistol....
     
  2. I had the feed ramp polished.
     

  3. ajole

    ajole Supporting Member

    35,324
    12,156
    NE Utah
    Break in your mags more, but until then, try widening the feed lips just a touch.

    I've only ever polished one feed ramp...I just don't think it helps much. 17 HPs, and 16 of them run fine without polishing anything.
     
  4. Is it only the 2nd round that jams? What happens after you clear it? Runs good/bad? Is it ejecting the spent cartridge? Is the slide going into full battery?
     
  5. cicpup

    cicpup Resident PITA Supporting Member

    15,993
    5,914
    Vermont
    Load only 7 or 8 rounds in the mag and see if it improves. If it does then the mag spring is too stiff and needs to break in some.
     
  6. undeRGRound

    undeRGRound ROLL wif Da MOLE! Supporting Member

    25,834
    1,919
    INDY
    :welcome:ShadowTX!

    Do you have just the one magazine? Could be feed lips like Ajolé said,
    or mag springs like ^^^ Rich-Pup said. I'd get a couple more mags
    and try those, maybe... it's a good idea to have spares and then you
    can mark them with Sharpie, paint pens, etc. It's rare that the JCP
    and JHP have feed issues, but yours sounds simple to fix.

    Have Fun! :D
     
  7. Give it some break-in time. Load & unload the magazine, but keep it loaded. Work the follower with a dowel or pencil. Hi-Point are not precision guns, but they work. Keep it clean & lubed.
     
  8. ShadowTX

    ShadowTX Member

    6
    0
    Ok
    -
    Thanks guys I'll try those suggestions.
    The mags are basically new and I've only run maybe a box thru the pistol.
    It's my backup for hog hunting. Worked fine new outta the box. It started jamming with hollow points and now with flat tips. I like it but it's just acting up on me.
    I usually only put 1 or 2 rounds thru it at a time. It's to make sure the boar is done kinda thing.
    Thanks again guys. I'll post up results.
     
  9. ShadowTX

    ShadowTX Member

    6
    0
    Fully loaded mag...
    One loaded in pipe from it - so actually round 2 of the mag jams...
     
  10. ShadowTX

    ShadowTX Member

    6
    0
    Seems the mag is keeping the round nose down causing it to flat face against the feed ramp.
    Are there any ways to fix or better mags out there?
     
  11. cicpup

    cicpup Resident PITA Supporting Member

    15,993
    5,914
    Vermont
    Break in the spring and adjust the feed lips.

    No.
     
  12. MachoMelvin

    MachoMelvin Well-Known Member

    If you have 5 magazines & your problem persist in ALL the mags you may have a gun problem?
    If you have 2 magazines & have a problem in both mags you could have a magazine problem or a gun problem. I have had NO luck with hollow points in several of my Hi Points.
    It sounds like you purchased the gun new & only recently started having problems. How long have you owned the gun & how many rounds through it?
    Sounds like you have a pistol, JH or JHP?
    Here is a link to Iberia Arms for several different magazines.

    http://www.iberiaxtras.com/store-2
     
  13. Browning 9 Guy

    Browning 9 Guy Premium Supporter Member

    Unfortunately, JCP 40 mags do want to hold the rounds a bit nose low. I always down load to 7 or 8 rounds and give the mag a good palm slap to coax those guys into the proper angle. Also, I bent the little rabbit ear lips outward to 90 degrees where they don't even touch the bullets. That helped.
     
  14. ShadowTX

    ShadowTX Member

    6
    0
    I did the lip bend thing and polished the ramp some.
    Seems to help a lil.
    *I know this isn't proper in any way, but I tried it, and it worked. I broke about 1/3 of a toothpick off in the gap between the forward side of the mag and the "bullet guide"?. The piece of plastic that sits between the bullet nose and the mag. It stopped the "play" and it feeds fine now.
    ?! Worked for me, y'all give it a try...
     
  15. ShadowTX

    ShadowTX Member

    6
    0
    Yes. Seems just the 2nd rd does.
    Runs fine after.
    Slings cases fine.
    Slide closes fine after I clear the 2nd round.

    I know - weird.

    I did post what got it to stop at the tail of this thread.
    Hope ur sitting down - lol