Hi-Point Firearms Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
Well I took the new TS out today, and it fired the first 50 rounds with no problem what so ever, even shot out to 100 yards with no problems hitting the target. Then the issues started. It is failing to eject the spend cartridge completely. I had my friend look at what was happening when it was fired and it looked like the little hook thing (sorry dont know the part name) that grabs onto the ridge of the cartridge was not grabbing it and the spent cartridge was just going straight up instead of out. Has anybody else had a similar problem and is it something I can possibly fix, or is the new gun going to have to go back to high point allready?
 

·
Premium Member
Joined
·
2,861 Posts
See that why it was so cheap, it was a scratch and dent :D, sorry, I couldn't resist 8)
 

·
Registered
Joined
·
1,156 Posts
comon Panoz!! it's the extractor. check and see if there is any crud under the hook, if so clean out with a toothbrush, matter of fact do it anyway. then put a drop of......(insert your fav lube here) but i use pro-gold grease, and then give her a try. they get crudded up real quick depending on ammo.
 

·
You know who I am
Joined
·
9,324 Posts
What brand of ammo were you using? HP doesn't recommend using Winchester White Box if that's what you were putting through it. I've never had problems with it, but I stopped using it when they said they didn't recommend it.
 

·
Premium Member
Joined
·
336 Posts
I'm not trying to cause an argument, and I type this with the up most respect(in other words, I'm not trying to sound like an a$$). But where does it say that HP says don't use certain ammo? I don't see it in writing, and when I called HP to get a safety check I asked what was the best ammo to use, and the lady on the phone said "any factory loaded ammo will be just fine". Am I over looking it somehow? Just wondering?

Sorry to get side tracked, and +1 to cleaning out the yuck under your extractor, it gunks up pretty quick with dirtier ammo.

Tt
 

·
Registered
Joined
·
557 Posts
What brand of ammo were you using? HP doesn't recommend using Winchester White Box if that's what you were putting through it. I've never had problems with it, but I stopped using it when they said they didn't recommend it.
Which is wierd from HP-- WWB is no worse than 99% of the range ammo out there...never understood that reasoning..
 

·
Premium Member
Joined
·
1,537 Posts
If that hook thing isn't working right the rifle is unsafe and cannot be repaired!!!!! Just to be safe pack it up and ship it to me at........
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top