Hi-Point Firearms Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
i picked up a new 709 ...my wifes new carry gun... i took it apart when i got it home to clean it out and was very suprised it didnt have much goop in it... well oiled but very little of the normal white goop...the wife and i went to the range to run some rounds through it and right off the bat the very first round FTE after we cleared it next 6 rounds perfect.. the next mag had a FTE bout 3 or 4 rounds in. we managed to put about 50 rounds through it but every mag we had 1 or more FTEs. the caseinf were only pulled about half way out of the barrel. now the second problem we had was my started to notice she wasnt hitting squat. after shotting a couplke of round and i was hitting squat i went to adjust the rear sight and notice the screw holding the read sight in place had worked its way free. it was loose enought i could move the site from side to side very very easily. i took it apar when we got home and cleaned to hell out of it and retightned the rear sites. i cycled 3 mags through by had with no problems. i gonna go back to the range tomorrow night to try it out again. just curious if anyone else has had either of these 2 issues. thanks on advance
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #3 ·
that could be the problem being the caseing only pulled about half way out of of the barrel. didnt have a problem with my pt111 or 24/7 though. im gonna go back to the range tonight and try again. i did a good cleaning of it last night so well see
 

·
Registered
Joined
·
1,837 Posts
Sounds like the brass could be expanding & sticking in the chamber, any idea if this could be the case?

Also, in b4 20 people saying "lol Taurus quality has really dropped etc"
It has IMO. I had a pt140 a bought a few years ago and 0 problems. A few of my local gun shops are saying repairs on the newer models has increased ALOT.
 

·
Premium Member
Joined
·
39 Posts
One think I've read in a few similar instances was a little extra material on the extractor. It appears that carefully sanding off the extra...it almost looks like flash from the MIM process, seemed to really straighten things out for a few people. That would definitely explain the FTEs.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #6 ·
i put 100 rounds through it sat night had 6 FTEs 3 only pulled out about half way, 1 was stuck to the extractor and 2 didnt clear the slide as it came back. the exractor does look like it has more material to it than my pt111 or 24/7 has. also the pt111 and 24/7 extractors are perfectly straight and the 709 has a slight curve to it.
 

·
Registered
Joined
·
258 Posts
Maybe its not getting enough bite due to the curve. What ammo are you using? I have had that problem with S&B Range Safe before but no other. (My Firestorm Mini 9 Pro, my C9 ran through the same ammo no problem)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top