Hi-Point Firearms Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I'm having a strange feeding issue in my C9. Whenever I have a full magazine, insert it in the grip and then rack the slide it gets stuck. I know what you're thinking, polish the feed ramp and tune the mags. I have when i first got aggravated with the problem and started looking for answers on here and elsewhere and not bragging, but they now look exactly like what all the repair videos and diagrams say they should look like. I have 3 magazines (2 8 round and 1 extended mag which I leave loaded) and this gun does it every single time on the first round no matter what magazine I use. I have had this gun nearly 2 years, 1000 rounds down the tube and even sent it in to HP in Mansfield. They replaced a few parts sent it back to me with an extra mag (which I appreciate), but the problem still continues. I have used every kind of ammo in every brand I can think of and have had the same problem every single time. The gun is also oiled properly and i just have no clue what else to do. I really do like Hi-Point. Not a hater at all. I plan on buying a 4095 ts this year if all goes well, but this is so frustrating. It looks like maybe the back of the magazine lips don't fit into the grooves in the slide. Does that even make sense? It can't be that right, not if all the other rounds load and fire properly right? What else can I do? Please help!!!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 · (Edited)
Thanks for the welcome everybody. @tallbump. I usually wack the bottom of the magazine and it usually goes in. When I fire the first round the second goes in just fine as does the 3rd, 4th, etc. If I don't load the magazine to capacity the first round usually but not always goes in properly. I just pull the slide all the way back and let it go like I do with my sccy cpx 2 and glock. No I don't hold on to it. I've had 3 other people do it just to make sure it wasn't me.

Thanks @rachgier

@talon I probably should do that huh? Just frustrated with it and thought this would be the place to ask.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Thanks @talon. I don't think I'm riding the slide, but I will make sure. I will take pictures tomorrow because that will probably make more sense than what I am saying.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
I am not riding the slide. My friends who tried it are also not riding the slide. I paid really close attention to that. My mag has the top round where it should be (IMO) before it's inserted, when I rack the slide it still gets stuck, it doesn't do it as often when I have the slide locked back when inserting the magazine. Here are some pics. I hope y'all understand I really am trying to get your help to fix the problem. I'm not trying to be a pain in the but or a wise guy and I'm sorry if I'm describing these things kind of funny. I'm not a complete noob, but I know you guys know more than me and I'm not just great with the lingo.
 

Attachments

·
Registered
Joined
·
14 Posts
Discussion Starter · #10 ·
For some reason when the slide is racked I think it is pushing the nose of the round down sometimes. It doesn't do that as often when the slide is locked back when inserting the mag, but still does it some time. It also gets stuck with the round not nose diving.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #13 ·
@cipcup Thank you! I will try that. Really do appreciate the help. It only screws up on full magazines. If I don't fill it to capacity there are no problems.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #14 ·
@talon, sorry for being ignorant, but could you explain the tapping seating thing with some more detail? Sorry. You mean like hitting the back of a full mag with your palm?

I have used every kind of brass I can find. FMJ and Jhp. Winchester, federal, Remington, hornady, I think even some monarch. All kinds of brass.

I got it back Friday and put about 50 rounds through yesterday.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #33 ·
So.... Apparently there is a lot to talk about on this subject. Thanks for all the input and ideas. So oil some spots. Maybe send it back again. Do something to the magazine other than leave them loaded for a long period of time. Oh and petition HP to add an extractor... But first do SWAGA's thing and post pics. Am I missing anything? I will do that soon.
 
1 - 12 of 12 Posts
Top