Hi-Point Firearms Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Well since I bought my used 995 I took it for the first time to the range today. I only fired 10 rds through it and had 3 bullets get jammed in the chamber I didnt shoot it after that. My only guess is its the cheap range ammo I'm using but I was a little dissapointed. On the other hand I got to shoot my new DPMS .223 with a lot of goodies, shoot 60 rds through it without a problem that made me very happy :D
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #2 ·
taking it again to the range tomorrow any suggestions from anyone so the bullets dont jam on loading? My friend who had it before me said he put a lot of rounds through it so I dont its the clip spring or the feed ramp but any suggestions would be great!
 

·
Premium Member
Joined
·
807 Posts
Stay away from the WWB & try some Magtech, Rem., American Eagle or Blazer Brass.
If you still have problems using other ammo then give us some details & maybe a pic or two & we should be able to figure it out.
 

·
Registered
Joined
·
60 Posts
I went through 150 rounds my first trip to the range, and I had a few failure-to-feed issues at first as well. My carbine was brand new though, not used.

I was using WWB, and out of the 150 rounds, I think I may have had half a dozen or so failures, nearly all of them in the first two mags.

Once I made it tough a couple of mags without the feeding issue, I tried a couple mags will firing rapidly and there were no problems at all. I intend to polish the living snot out of my feed ramp this weekend and hopefully I'll get some more range time to see if that helps, or if my problems really were just because it was 'new' and still in the break-in period.
 

·
Registered
Joined
·
126 Posts
FYI

I like Winchester ammo in general- works great in most firearms I've owned over the years.

But when I got my first High-Point, I called to ask what ammo they recommended.

"Just about everything except Winchester," they told me. I was shocked. "We're not sure why, " they added, "but it seems to jam in our guns."

Well, my first time out, I burned through a box of Remington with no problems. Then, I tried some PMC, no trouble. Finally, I opened a box of Winchester and loaded up. I had a problem every 10-15 rounds.

I really can't figure it out. But I now stay away from Winchester for my High-Points.
 

·
Registered
Joined
·
51 Posts
995 is supposed to be eating everything. My suggestion to you, send your new-used 995 to to hi-point. Their no-question life time warranty is the best. You will get it back in short order in like-new condition! Quite a few members in several forums reported that it works this way!
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #9 ·
I think its my clip, I loaded 3 rds into it and the clip jammed and would not let me load anymore, so I pull them all out and the (sorry I dont know the actual term) slider was jammed down in the clip, hi-point will replace the clip right, I should probably just send the whole gun.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #12 ·
you think I should just send them the magzine first?
 

·
Registered
Joined
·
60 Posts
That's what I would do. I wouldn't send them the carbine, as you don't know if there is even anything wrong with it. I'd send them the mag and when you get the new one, go shooting and see how things fare.

Hi-Point's turn-around-time seems to be pretty good. You'll have your new mag within a week or so, usually.

If you have problems with your carbine after you receive your new mag, then call Beemiller and get an RMA, send them your rifle, and wait a few days for them to send it back.

Of course, their customer service is so good that if you did choose to send them your 995 with the mag, they'd accept it, work it over, and send it back to you in in just a few days, so it's really up to you.

You could also just call them and ask them what they think you should do, either send just the mag or the whole carbine. That's probably your best course of action. :)
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #14 ·
Got my new clip today! Wow what quick service took less then a week! Now just to try it out at the range :yay!:
 
1 - 16 of 16 Posts
Top