Hi-Point Firearms Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Ok here is my issues
I got my 995 new and took it to the range and put about 100 rounds thru it, everything worked great. I got a new ATI stock had to do a little sanding and filing to make it fit correctly. Only issue I notice is the mag release is a little tight. I go to the range today to try it out and here are the issues I found

1. When pulling the charge handle back to load the 1st round , handle does not cycle completely or load the round until I pull the charge handle a 2nd time and them loadeds the round and cycles fine. After 1st round is loaded go's thru all 10 rounds fine. When no mag is in you can cycle the charging handle fine , not stiff does not hang works perfect.

2. Mag release button is still stiff but getting better, but everytime I have to hold the button in and smack or tap the stock hard to make the mag fall out.

Any suggestions beside learn to live with it ?
Ol and by the way after ATI stock install almost no recoil and very very very accurate, I mean noticeably better than with factory stock. If i can fix these 2 little bugs I will love this thing
 

·
Registered
Joined
·
60 Posts
First, start here.

My ATI stock came with a mag release button. I used it instead of the one that came with the 995. It made a difference.

As for your other issues, I had them as well. See this post for my solution.

Rest assured that your problems are normal and easily overcome. :)
 

·
Premium Member
Joined
·
491 Posts
i think issue #1 requires taking a little material off the top of the back cover on the ati stock, the bolt may be rubbing on it when you charge the bolt. pretty common problem.
 

·
Registered
Joined
·
850 Posts
I just put the ATI stock on my 995 as well, I've actually had this problem with my 995 since I've had it. The slide always hangs up the first time I pull it back and I have to kinda pull it back and 2nd time and smack it into place. I've just learned to deal with it. I've never had and jams of any kind in the 995 so I just live with it. It never bothered me enough to try and fix it or get it fixed.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
i think issue #1 requires taking a little material off the top of the back cover on the ati stock, the bolt may be rubbing on it when you charge the bolt. pretty common problem.
I will try that but to be honest the mag hanging and having to smack it to make it fall out is the biggest issue. Any suggestions for that ?
 

·
Registered
Joined
·
16 Posts
When my 995 was new, the bolt slide was sluggish and I lubricated it with gun grease.......No problems after that. The ATI stock required some shaving with my handy drimmel tool to get a good clean fit.........Biggest problem I have with my 995 is jams in the breach when cycling. It only happens when I use the lead head 9mm rounds from Walmart. The FMJ rounds work great and they are only $8.97 at WallyWorld.
 
1 - 7 of 7 Posts
Top